Velleman Oscilloscope: Windows 7
by Mr. David Fritz
Installing Oscilloscope Drivers

• Unzip the Velleman scope drivers from Velleman web site to somewhere easy to find (e.g. c:/Vscopec)

• Plug your scope into the USB port
• Click: Start > Control Panel > System > Device Manager

• Scroll down to "PCSGU250 Device"
  – Right Click "PCSGU250"
  – Click "Update Driver Software..."
  – Click "Browse my computer for driver software"
    • Browse to where you unzipped the driver directory

• "PCSGU250Driver_WinUSB"
  – Click the directory
  – Click "OK"
  – Click "Next" and follow the directions
You should now have the drivers installed

The scope software should be able to find the USB scope.

Launch the scope control software.

Start > Programs > Velleman > PcLab2000LT

(You will probably want to make a shortcut)
What if the software doesn’t find the scope?

• You may see a pop-up that says you are in Demo mode because the software did not find the scope.
  – This is usually not a problem.

Click Options > Hardware Setup > PCSGU250 > OK

• The software will find the scope and the blue light will illuminate on the front of the scope.
If you still can’t get the scope to connect...

- Make sure that you installed the software and drivers from the Velleman website.
  - The CD included with your scope does not contain the latest versions.

- Try re-installing the drivers from the Velleman web site.

- See the ECE Tech Support Guru for assistance.
  - Branden McKagen
  - bmckagen@vt.edu
  - 346 Whittemore Hall
  - 9:00-Noon M-F, 1:30-5:00 MWF

- If you have a scope that will not work, see a GTA in the OpEL for assistance.
Using the Velleman Oscilloscope
Sine wave with a DC offset

\[ V(t) = A + B \sin(2\pi ft) \]

- \( f \) = frequency in Hz
- \( A \) = DC offset voltage (average voltage)
- \( B \) = Sine amplitude

- \( V_{pp} = 2B \)
- \( V_{max} = A + B \)
- \( V_{min} = A - B \)

**120 \( V_{RMS} \) from the AC line**
- Has a peak voltage of 170V
- Has a PP voltage of 340V
- \( A = 0, \ B = 170, \ f = 60 \)
Electrical Power and RMS voltage

• Electrical Power \( P = \text{Voltage} \times \text{Current} \) (V x I)

• Our dilemma: The average voltage value of a sinusoidal, square, triangular, or ramp waveform with no DC offset is 0V. \( P = ? \)

• \( P = V \times I = V \times V/R \) (As \( V \)↑, \( I \)↑ into a load. Ohm’s Law says \( V = I \times R \)).

• To calculate the power produced by an AC voltage, we must use the effective voltage, called the "Root Mean Square voltage" (abbreviated \( V_{\text{RMS}} \)). Effective \( V_{\text{RMS}} \) is also called “True \( V_{\text{RMS}} \)” by many instrument manufacturers.

\[
\text{Effective AC voltage is given by} \quad V_{\text{RMS}} = \left[ \frac{1}{T} \int_{0}^{T} v^2(t) \, dt \right]^{\frac{1}{2}}
\]

• 120VRMS and 120VDC will produce the same power in a given load.
True $V_{\text{RMS}}$ from DMM measurements: (works with some meters for a sine wave with an offset)

$$V_{\text{RMS}} = \sqrt{A^2 + B^2/2}$$

- Take the $V_{\text{DC}}$ measurement. (This is $A$.)

  Note: your DMMY64 does not always read the DC component if there is significant AC present.

- Take $V_{\text{AC}}$ measurement. (This is $AC_{\text{RMS}} = B / \sqrt{2}$)

- Square $V_{\text{DC}}$, square $V_{\text{AC}}$, add them together, take the square root of the sum.
Remember this:

• \( \sin(x) \) varies from \(-1\) to \(+1\)

  so \( B\sin(x) \) varies from \(-B\) to \(+B\) and (for voltages) \( V_{pp} = 2B \)

• The scope has an “Amplitude” measurement that is actually the same as \( V_{pp} \).

  \textbf{Amplitude on the scope \( \neq B \)}

• The DMMY64 assumes all time varying signals are sinusoids.

  This meter will provide an \( AC_{RMS} \) measurement for pure sinusoids; it will not accurately measure anything that is not either pure DC or a pure sinusoid between 40Hz and 400Hz.
Oscilloscope Basics

• The scope graphically displays a time varying voltage waveform.

• The scope can be used to determine waveform amplitude, frequency, period, phase, DC and AC components, noise, shape, etc.

• NOTE: The oscilloscope is designed to capture and display time varying waveforms – it is not the best instrument for measuring DC voltages!
Displaying the input waveform.

• An A→D converter captures a series data points on the waveform. The 8 bit samples provide a resolution of 256 possible voltage levels.

• These points are stored in memory and then displayed on the screen, using interpolation to smooth the waveform shape between data points.

• The accuracy and resolution depend on the vertical scale selected. For best measurement accuracy, you should always try to display the waveform as close to full scale as possible.
Main Oscilloscope Components

• **Vertical display controls**
  Scales the input voltage to set the size and position of the waveform.

• **Horizontal display controls**
  Sets the “sweep rate” (time / division) and adds a horizontal position control.

• **Trigger System and controls**
  If the horizontal sweep begins randomly, the waveform moves around.

  The trigger stabilizes the waveform by controlling where, on a waveform’s voltage and slope, the display trace begins each time.

• **This scope also has a built-in signal generator.**
The Velleman scope display
Vertical controls

- Turn the channel display on & off (toggle the On button)
- Set the vertical scale (press desired scale on Volts/Div.)
- Set vertical position (slide bar)
- Set input coupling (select buttons at bottom)
- Set probe type (select buttons at bottom center)
  - use 1x for the black coax probes from Electronix Express.
  - use 1X or 10x for the probe supplied with Velleman scope
- Autoset can be friend or foe!
Scope Input Coupling

Input coupling may be:

• **DC Coupling** displays all of a signal, including any DC offset.
  True RMS measurement requires DC coupling.

• **AC coupling** strips the DC component from a waveform, leaving only the time varying portion of the signal.

• **GND** disconnects the input signal.
Horizontal controls

- To the right of the waveform display area is the Time/Div. horizontal scale setting buttons.
- The Run button enables the Horizontal display.
- The single button is used to display a single horizontal capture.
- Below the waveform display area is a slide bar to move the waveform sideways along the horizontal scale.
Trigger controls

• Turn the trigger on and off (use the buttons). If the trigger is off, the display will free run.

• If the trigger is on and you see Waiting for trigger...

Select the trigger source (buttons)

Select whether to trigger on rising edge or falling edge of the waveform. (buttons)

Adjust the trigger voltage level (slide bar) until you see Running.
Trigger markers tell you what the trigger is doing.

There are markers on the edges of the scope waveform display that correspond to the waveform’s

- trigger voltage level
- trigger time (appears when you move the horizontal position slide bar to display the waveform before the trigger occurred)
Signal Generator built into the Scope

- Generates sine, square, and triangle waveforms, plus other functions. Select the waveform type with the buttons.

- Select frequency range with the buttons, then adjust the frequency with the slider.

- For Amplitude and DC offset, adjust the levels with the sliders or type the values into the boxes.

The generator output (here) is set for a 500Hz, 5Vpp sine wave with a 0.98V DC offset - into a high Z load.
Starting the oscilloscope

1. Install the scope software from the Velleman web site - not the CD
2. Install the USB drivers from Velleman web site - not the CD
3. Attach the scope to the USB port
4. Launch scope control software

Start > Programs > Velleman > PcLab2000LT

(You will probably want to make a shortcut)
What if the software doesn’t find the scope?

• You may see a pop-up that says you are in Demo mode because the software did not find the scope.

  This is usually not a problem.

• Click Options > Hardware Setup > PCSGU250 > OK

• The software will find the scope and the blue light will illuminate on the front of the scope.
If you still can’t get the scope to connect...

• Make sure that you installed the software and drivers from the Velleman website. The CD included with your scope does not contain the latest versions.

    Try re-installing the drivers from the Velleman web site.

• See the ECE Tech support Guru for assistance.
    Branden McKagen
    bmckagen@vt.edu
    346 Whittemore Hall
    9:00-Noon and 1:30-5:00 Monday - Friday

• If you have a scope that will not work, see a GTA in the OpEL for assistance.
Your scope is connected, what now?

- First do a calibration. With no cables connected to the scope, click Options > Calibrate > OK.

  Wait for the Calibration complete pop-up and click OK.

- Always run a calibration before you begin measurements if the scope and/or computer have been off.
Connecting the Generator and Scope to a load

Connect the probe leads from the scope **CH1 input** and the scope **Generator output** to the load resistor on the protoboard.

Insert wires into the breadboard and clip the probe leads to the wires.

*Do not attach the measurement clips directly to the load resistor.*

- The heavy probe leads may pull the resistor out of the breadboard
- Using wires makes it easier to change the resistor value.
Set up the scope’s Signal Generator

• Select the waveform type with the buttons.

• Select frequency range with the buttons, then adjust the frequency with the slider.

• For Amplitude and DC offset, adjust the levels with the sliders or type the values into the boxes.

In this case, the generator output is set for a 500Hz, 5Vpp sine wave with a 0.98V DC offset into a high Z load.
Set up the scope for measurements

1. Connect a BNC / Clip lead from the signal to be measured to the CH1 and/or CH2 Input(s).

2. Click Run.

3. Turn on the Trigger and the CH1 and/or CH2 display(s).

4. Adjust the vertical, horizontal, and trigger controls to get your waveform on the screen.
Visually measuring the waveform

On the scope display, $V_{\text{max}}$, $V_{\text{min}}$, $V_{\text{pp}}$, and period can be obtained by

- counting the number of divisions
- multiplying by the vertical scale for voltages
- multiplying by the horizontal scale for time period.
Measure the Waveform Parameters

- Click View > Waveform Parameters... This opens a pop-up for measurements.
- Click each box to place (or clear) a check for measurements you wish to include (or exclude).

DC Mean is approximately the DC offset
AC RMS is $V_{RMS}$ without the DC offset
AC + DC RMS is the True $V_{RMS}$
Amplitude is the same as Peak-to-Peak
“Waveform Parameters” Accuracy

• A waveform that vertically occupies most of display will have more measurement accuracy than a waveform that is small on the display.

• Best accuracy seems to require at least two waveforms horizontally.

• The measured values will be reasonably accurate as long as the scope display is running.

• If you see “?” after the value, the waveform measurement does not fit into the display window and is out of measurement range.

• If you have “Waiting for trigger” showing, any waveform changes will not appear in the display or Waveform Parameters measurements.
Using Cursors

To obtain data at specific points on the displayed voltage vs. time graphs, you can turn on the cursors by clicking on Markers (DSO) under View on the scope toolbar.
To find the difference in time between two points in time on a curve, position the two vertical lines by click-and-dragging each line to the appropriate point on the trace.

\[ \text{dt} \] is the absolute value of the difference in time between the two vertical cursors. \[ 1/\text{dt} \] is the reciprocal of that difference in time, expressed in Hz.
To find the difference in voltage between two points on the same trace, position the two horizontal lines by click-and-dragging each line to the appropriate point on the trace.

$dV$ is the absolute value of the difference in voltage between the two horizontal cursors. The two voltages in parenthesis after $dV$ are the voltages used in the calculation of $dV$. 
You can use the cursors to find the difference in voltage between the two traces. However, you should make sure that the coupling on Channel 1 is the same as the coupling on Channel 2,

DC coupling on both channels will enable you to measure the difference in voltage between the two traces using ground as a reference voltage.

AC coupling will only allow you to determine the difference in the ac portion of each signal.

You should not use two different types of coupling.