Notes for OrCAD PCB Designer

Contents

OrCad Capture Schematic Editor ................................................................. 4
OrCad Directories ..................................................................................... 4
Quick start and place components ......................................................... 4
Adding Net Aliases ................................................................................. 4
Changing the size of a worksheet ............................................................ 5
Label the design ..................................................................................... 5
Design rule check .................................................................................. 6
Set Up Paths for Footprints .................................................................. 6
Assign Footprints .................................................................................. 6
Repeat Design Rules Check .................................................................. 6
Print the schematic ................................................................................. 6
Create a Blank board ............................................................................. 7
Create a Netlist ...................................................................................... 7

OrCad PCB Editor .................................................................................. 8
Place Components on PCB .................................................................. 8
Setup Vias ............................................................................................... 8
Route the Board .................................................................................... 8
Mistakes ................................................................................................. 8
Add text ................................................................................................. 10
Add Mounting holes .............................................................................. 10
To Change Board Dimensions .............................................................. 10
To change Package / Route Keepin ....................................................... 10
Add Solid Fill ground plane .................................................................. 10
Preparation for Single Sided Routing .................................................... 12

AutoRoute with OrCAD PCB Router ...................................................... 12
For Single Sided Boards ....................................................................... 12
Importing the design to PCB editor ...................................................... 13
Preparing a Single Sided Design for PCB manufacturing .................. 13
Preparation for Double Sided Routing .................................................. 15
AutoRoute with OrCAD PCB Router ...................................................... 15
For Double Sided Boards ................................................................................................................. 15
Importing the design to PCB editor .................................................................................................. 16
Preparing a Double Sided Design for PCB Manufacturing (Bottom) ........................................ 16
Preparing a Double Sided Design for PCB Manufacturing (TOP) ............................................ 17
Disappearing GND and POWER Nets .......................................................................................... 17
Creating files for Routing on machine. ......................................................................................... 19
Create a board outline ..................................................................................................................... 19
Create artwork .................................................................................................................................. 19
Problems .......................................................................................................................................... 19
Drill file set up .................................................................................................................................. 19
Creating files for manufacture by PCB Train / Newbury ............................................................ 20
Files required in Zip File ................................................................................................................ 20
Setup ................................................................................................................................................ 20
Create Artwork Board Outline ........................................................................................................ 20
Create Artwork Silkscreen Top ......................................................................................................... 21
Create Artwork Soldermask Top ........................................................................................................ 21
Create Artwork Copper Etch Top ..................................................................................................... 21
Create Artwork Copper Etch Bottom .............................................................................................. 22
Create Artwork Soldermask Bottom and Silkscreen Bottom ........................................................ 22
Create drill file .................................................................................................................................. 22
Hints and tips ....................................................................................................................................... 24
Tracks highlighted in PCB editor...................................................................................................... 24
Display Options Menu ..................................................................................................................... 24
Set DRC limits .................................................................................................................................... 24
Change width of Clines .................................................................................................................... 24
Errors ................................................................................................................................................ 24
Error 32007 ....................................................................................................................................... 24
Error 32006 ....................................................................................................................................... 24
Error 36004 ....................................................................................................................................... 25
Design freezes in window ................................................................................................................ 25
Pinning Option Find and Visibility windows .................................................................................. 25
Changing Text Size .......................................................................................................................... 25
Create Parts in Schematic capture ................................................................................................. 26
Creating Footprints In PCB Editor ................................................................................................. 27
EDP2 Common Problems

EDP2 Foot print Libraries not found.

Wrong footprint.

Not enough pins on schematic part for foot print.

Switch numbered incorrectly.

Standard via used, Not GU-VIA 80.

Tracks / pins / symbols highlighted in masks.

Scaling issues with Photo-masks.

Using PSpice battery symbol in Schematic Editor.
OrCad Capture Schematic Editor

OrCad Directories
1. On your network drive create a folder called OrCad.
2. In this folder create a folder called Footprints; this is where you should store your personal footprints.
3. Also create a folder called Library; this is where you should store any personal schematic libraries.
4. Also create a folder called Design; this is where all the schematic designs should be stored.
5. For each new design create a folder named after the design in the Design folder.
6. Inside each new design folder create a folder called allegro.

Quick start and place components
1. Open OrCad capture.
2. Use OrCad PCB Designer PSpice if given the option.
3. Select FILE > NEW > PROJECT
4. Enter a project name.
5. Select Schematic.
6. Browse to the Project Directory created above, or use create dir.
7. Open Place Part menu, Add Libraries e.g. Resistor (Discrete), Capacitors and Transistors.
8. Select Library, select Component, click add new part.
9. Use right click menu to orientate, left to place, repeat or right click to end mode.
10. After finishing placing left click to add values to components.
11. Select part and right click edit part.
12. Click on a pin right click to edit properties, such as leg length.
13. Choose OPTIONS > PART PROPERTIES.
14. Add a new property named “NC”.
15. For label enter the pin number which is not connected.
16. Separate with commas for multiple entries
17. To exit click on close window, to save changes and update all similar parts.
18. Double click device to pull up part schematic, select pins page.
19. Mark pins which are not connected.
20. Close page and save changes.
21. Add Power nets (Place Power) and Ground nets (Place Ground).
22. Connect components using place wire, left click to start, again to turn corner, end by right click > end mode.
23. Add text to connectors to label pins.

Adding Net Aliases
1. For connecting two lines on one page, without a complicated mess of lines.
2. PLACE > NET ALIAS
3. Enter Name in the pop up.
4. Select the desired colour.
5. Rotate the text if required.
6. Click OK.
7. Move to above desired line, click to place Net Alias.
8. Move to the other end of the connected line, click to place Net Alias.

**Changing the size of a worksheet**
1. Select the design overview tab.
2. Right click on the Schematic page, select Schematic Page Properties.
3. Edit the page size from the displayed options.
4. Click Ok to close.

**Label the design**
1. In the Bottom right hand corner of Page 1 there is an information box.
2. Double click the <Title> to change the title of the design.
3. Double click the <Rev> to change the Revision of the design. (A, B, C...)
4. Double click the <Doc Number> to edit the document number.
5. To add a field select the entire box, right click and select EDIT PROPERTIES.
6. In the Schematic Property Editor, click NEW PROPERTY.
7. Enter the Title for the new property. (e.g. author)
8. Enter the Value for the new property. (e.g. Team A)
9. Click APPLY.
10. Save and close the Schematic Property Editor.
11. Double click the new property to edit it.
12. Choose whether to display name, value or both.
Design rule check
1. Minimise schematic page to reveal Project manager page.
2. Highlight the design.
3. TOOLS > DESIGN RULES CHECK.
4. Run Electrical rules.
5. Check for errors, (highlighted with green circles)
6. Alter design to resolve issues
7. ACTION > DELETE EXISTING DRC MARKERS removes markers
8. Repeat until DRC passes.

Set Up Paths for Footprints
1. START > PROGRAMS > OrCAD PCB EDITOR
2. Choose SETUP > USER PREFERENCES.
3. Expand Paths in the list of categories, choose the Library folder.
4. Add a location to psmpath by clicking on the 3 dots to the right of psmpath.
5. Make the location Q:\allegro\pcb_lib\symbols. (or whatever the network drive is called)
6. Click Ok to close and the move the new location above the one that is already there to make it the default location.
7. Repeat this for the padpath, linking it to the padstacks directory on Q.
8. Repeat this for your personal footprints held on your network drive.
9. Close the User Preferences editor and then OrCAD PCB designer.

Assign Footprints
1. Highlight all components by dragging rectangle around them.
2. EDIT > PROPERTIES to bring up Properties spread sheet.
3. Enter name of footprint in to relevant field on spread sheet.
4. All Glasgow University Footprints are prefixed with GU-.

Repeat Design Rules Check
1. Repeat the design rules check with the Physical rules as well.

Print the schematic
1. Highlight area to be printed, FILE > PRINT > SET
2. Print.
Create a Blank board
1. Using windows explorer, create an allegro directory in the project file.
2. Start PCB editor.
3. Select FILE>NEW to open the new project box.
4. Set the Drawing type to Board (wizard).
5. Navigate to the new allegro directory, to set it.
6. Name the board something sensible e.g. firstproject.brd.
7. Click OK to continue wizard.
8. First page is an information page, click next to skip.
9. 2nd Page asks for a board template, we do not have one, click no.
10. 3rd Page asks for a tech file, we do not have one, click no.
11. And for a parameter file, we do not have one, click no.
12. 4th Page asks for a board symbol, we do not have one, click no.
13. 5th Page, select units to be Mils, drawing size A, leave the origin at the centre.
14. 6th Page, select Grid spacing to be 100 Mils, leave etch layers at 2, ignore artwork files.
15. 7th Page, leave the 2 layers as top and bottom and the types as routing.
16. 8th Page, Minimum Line width to 25 Mil, the other boxes will autofill.
17. For Default Via Padstack click on the button and select GU-VIA80.
18. 9th Page select rectangular board.
20. Set Route Keepin to 100 Mil, Package Keepin to 250 Mil.
21. 11th page Click finish to complete.

Create a Netlist
1. In the Project Manager, highlight the design.
2. TOOLS>CRAETE NETLIST
3. In the PCB Editor Tab, Set PCB Footprint to PCB Footprint.
4. Check the Create PCB Editor Netlist.
5. Set Netlist Files Directory to allegro.
6. Check Create or update PCB Editor Board (Netrev).
7. For Input File Board, navigate to the Blank board we created previously.
8. C:\Users\ap203d\Documents\OrCAD Projects\First Project\allegro\First Project.brd
9. For Output File Board use new allegro directory select another sensible name.
10. Select open board in OrCAD PCB editor.
11. Click OK, ignore the warning, PCB should launch with the new board the components are invisible
OrCad PCB Editor

Place Components on PCB
1. Pin Find menu (right hand side) so that is visible all the time.
2. Click all off and then select symbols. (This allows complete devices to be selected and manipulated instead of individual pads etc)
3. Choose PLACE > MANUALLY to bring up the place menu.
4. Tick a check box and then move on to the board, place a component by left clicking.
5. Use the mirror command to place device on back of board.
6. Repeat until all the parts have been placed, close the place box by right clicking and DONE.
7. Orientate the devices by selecting them and spinning them.
8. Update DRC, TOOLS > UPDATE DRC.
9. Check box at bottom right of page has turned green, errors are highlighted with a red butterfly.
10. Save the design, use a different name if required to create multiple save points.

Setup Vias
1. SETUP > CONTRAINTS > PHYSICAL
2. PHYSICAL CONSTRIANTS SET > SET ALL LAYERS
3. Under Via column select cell with VIA:GU-VIA80.
4. Right Click EDIT >CHANGE
5. Delete VIA: and add GU-VIA80 if necessary.

Route the Board
1. Select correct layer to lay tracks on, green component top, and yellow bottom.
2. Choose ROUTE > CONNECT. This alters the Options window on the right hand side.
3. Change the Act (active) layer from top to bottom (the top selection box).
4. Change the Alt (Alternative) layer from Bottom to top.
5. Set line lock to 45 degrees.
6. The find panel should have been automatically set up for the relevant parts.
7. Click between pads to lay tracks, using the rats nest thin blue line as a guide.
8. Complete all the sections of the rats nest and right click done when complete.
9. Save the design.

Mistakes
1. Right click and choose Oops, removes last section of track laid.
2. Right click and cancel undoes a completed action.
3. EDIT > UNDO to go further back.
4. Reload without saving to try again.
5. In Find highlight ALL ON, then ALL OFF, then CLINE SEG to be able to highlight Tracks.
6. They can then be deleted or moved.
7. Use route connect to redraw the track.
8. EDIT > VERTEX and EDIT > DELETE VERTEX Are also useful.
9. Save the design.
Add text
1. Choose ADD > TEXT.
2. Select Active Class to be Etch.
3. Select Layer to be Bottom.
4. Alter marker size, text block and rotate to suit.
5. Enter Identity information, board rev etc.

Add Mounting holes
1. PLACE > MANUALLY. Select Advanced Tab.
2. Display Definitions from > Library TICK BOX.
3. Select Placements list tab, Highlight Mechanical Symbols.
4. Place GU-MOUNTING156 holes in corners of the board.

To Change Board Dimensions
1. SETUP > OUTLINES > BOARD OUTLINE
2. Select edit, the board outline is highlighted.
3. Click once on the boxes on the board out line to select a line to change.
4. Drag the line to the required position.
5. Click for a second time to release the line.

Or
1. Select Create, and confirm you wish to delete the current board outline.
2. Either Draw a rectangle, click in the bottom left, and again in the top right.
3. Or Place a rectangle.
4. Define the width and the height in the boxes.
5. Place the bottom left corner with one click in the main window.

To change Package / Route Keepin
1. SETUP > AREAS > PACKAGE KEEPIN (OR ROUTE KEEPIN).
2. Click once to start, click again to place each corner.
3. Finish by clicking in the original location.

Add Solid Fill ground plane.
1. SHAPE > GLOBAL DYNAMIC PARAMETERS
2. Shape fill Tab > Line width to 25, spacing to 25.
3. Void control tab > Check Artwork Format. (Gerber 274x)
4. Clearances > Set to 25.
5. SHAPE > RECTANGULAR
6. In OPTIONS > Etch to Bottom
7. Fill Type > Dynamic Copper
8. Assign Net Name > GND (or leave as dummy to not connect to anything)
9. Draw rectangle around board outline.
10. SHAPE > DELETE ISLANDS.
11. Remove islands, use visibility to select a layer.
12. Islands should now be highlighted in grey.
13. Double click on an island to delete it.
Preparation for Single Sided Routing

1. SETUP > CONSTRAINTS > PHYSICAL Launches Constraints Manager.
2. NET > ALL LAYERS (Highlight) (left hand window)
3. For GND, VCC, VEE, Change LINE WIDTH MINIMUM to 50mil.
4. File close to return to PCB editor.
5. Save the design.

AutoRoute with OrCAD PCB Router

1. In PCB Editor FILE > EXPORT > ROUTER.
2. Click RUN to create *.dsn file (where * is the file name)
3. Click CLOSE.
4. Start OrCAD PCB Router
5. In Startup POP menu,
7. Do File > BROWSE select *rules.do file.

For Single Sided Boards

1. VIEW > LAYERS to bring up the Layers Menu.
2. Beside the TOP Layer change the symbol to the circle with a line through it to deselect the top layer (component side) and only use the bottom layer.
3. Change the symbol beside TOP or BOTTOM to change the way the board is routed.
4. Close the window.
5. AUTOROUTE > ROUTE
6. Leave SMART selected click OK.
7. Wait while the design routes.
8. Check that it has 0 unconnected Nets.
9. AUTOROUTE > POST ROUTE > SPREAD WIRES
10. AUTOROUTE > POSTROUTE > (UN)MITRECorners
11. REPORT > ROUTE STATUS
12. Check route length, check unconnected length = 0.
13. FILE > QUIT.
14. SAVE and QUIT.
Importing the design to PCB editor
1. In OrCAD PCB Editor.
2. *FILE > IMPORT > ROUTER.*
3. Select the session file (.ses) created when the Router was closed.
4. It should have the same file name as the current design.
5. The tracks should now be displayed over the placed components.
6. *FILE > SAVE AS*
7. Add an R to the end of the file name to indicate it has been routed.

Preparing a Single Sided Design for PCB manufacturing
1. *FILE > SAVE AS.*
2. Add SB to file to indicate Single sided (S) and Bottom (B).
3. *DISPLAY > COLOUR VISIBILITY.*
4. Turn GLOBAL VISIBILITY > OFF (top right corner)
5. Highlight the DISPLAY folder.
6. Turn the box beside BACKGROUND to White. (Click white on the palette, then the box).
7. Highlight BOARD GEOMETRY folder.
8. Turn the Box beside Outline ON.
9. Change the colour of the box beside Outline to Black.
10. Highlight Stack up folder.
11. *SUBCLASS > BOTTOM*
12. Turn ON Pin, VIA and ETCH
13. Change the colour of the boxes beside these to Black.
14. Click Apply to make the outlines appear.
15. *SUBCLASS > FILMMASKBOTTOM*
16. Turn on ALL.
17. Change the boxes beside PIN and VIA to White.
18. Click Apply and OK
19. *OPTIONS > PIN* (right hand window)
20. Select Filmmask bottom.
21. *FILE > PLOTSETUP.*
22. Scaling factor = 1.
23. Default line width = 10.
24. Colour is checked.
25. Sheet contents is checked.
26. CLICK OK.
27. *FILE PLOT* to print.
28. Select SETUP
29. Change printer to PDF creator click OK
30. Change dpi to 3600
31. Click OK to print
32. FILE > SAVE.
Preparation for Double Sided Routing
1. SETUP > CONSTRAINTS > PHYSICAL Launches Constraints Manager.
2. NET > ALL LAYERS (Highlight) (left hand window)
3. For GND, VCC, VEE, Change LINE WIDTH MINIMUM to 50mil.
4. If Column VIAS indicates VIA:GU-VAI80.
5. EDIT > CHANGE.
6. Highlight VIA and REMOVE.
7. Close POPUP.
8. File close to return to PCB editor.
9. Save the design.

AutoRoute with OrCAD PCB Router
1. In PCB Editor FILE > EXPORT > ROUTER.
2. Click RUN to create *.dsn file (where * is the file name)
3. Click CLOSE.
4. Start OrCAD PCB Router
5. In Startup POP menu,
7. Do File > BROWSE select *rules.do file.

For Double Sided Boards
1. VIEW > LAYERS to bring up the Layers Menu.
2. Change the symbol beside TOP or BOTTOM to change the way the board is routed.
3. Close the window.
4. AUTOROUTE > ROUTE
5. Leave SMART selected click OK.
6. Wait while the design routes.
7. Check that it has 0 unconnected Nets.
8. AUTOROUTE > POST ROUTE > SPREAD WIRES
9. AUTOROUTE > POSTROUTE > (UN)MITRECORNERS
10. REPORT > ROUTE STATUS
11. Check route length, check unconnected length = 0.
12. FILE > QUIT.
13. SAVE and QUIT.
Importing the design to PCB editor
1. In OrCAD PCB Editor.
2. FILE > IMPORT > ROUTER.
3. Select the session file (.ses) created when the Router was closed.
4. It should have the same file name as the current design.
5. The tracks should now be displayed over the placed components.
6. FILE > SAVE AS
7. Add an R to the end of the file name to indicate it has been routed.
8. Add DB to file to indicate Double sided (D) and Bottom (B).
9. Add DT to file to indicate Double sided (D) and Top (T).

Preparing a Double Sided Design for PCB Manufacturing (Bottom)
1. FILE > OPEN.
2. Open the Routed and Double sided Bottom (RDB) File.
3. DISPLAY > COLOUR VISIBILITY.
4. Turn GLOBAL VISIBILITY > OFF (top right corner)
5. Highlight the DISPLAY folder.
6. Turn the box beside BACKGROUND to White. (Click white on the palette, then the box).
7. Highlight BOARD GEOMETRY folder.
8. Turn the Box beside Outline ON.
9. Change the colour of the box beside Outline to Black.
10. Highlight Stack up folder.
11. SUBCLASS > BOTTOM
12. Turn ON Pin, VIA and ETCH
13. Change the colour of the boxes beside these to Black.
14. Click Apply to make the outlines appear.
15. SUBCLASS > FILMMASKBOTTOM
16. Turn on ALL.
17. Change the boxes beside PIN and VIA to White.
18. Click Apply and OK
19. OPTIONS > PIN (right hand window)
20. Select Filmmask bottom.
21. FILE > PLOTSETUP.
22. Scaling factor = 1.
23. Default line width = 10.
24. Colour is checked.
25. CLICK OK.
26. FILE PLOT to print.
27. FILE > SAVE.
Preparing a Double Sided Design for PCB Manufacturing (TOP)

28. FILE > OPEN.
29. Open the Routed and Double sided TOP (RDT) File.
30. DISPLAY > COLOUR VISIBILITY.
31. Turn GLOBAL VISIBILITY > OFF (top right corner)
32. Highlight the DISPLAY folder.
33. Turn the box beside BACKGROUND to White. (Click white on the palette, then the box).
34. Highlight BOARD GEOMETRY folder.
35. Turn the Box beside Outline ON.
36. Change the colour of the box beside Outline to Black.
37. Highlight Stack up folder.
38. SUBCLASS > TOP
39. Turn ON Pin, VIA and ETCH
40. Change the colour of the boxes beside these to Black.
41. Click Apply to make the outlines appear.
42. SUBCLASS > FILMMASKTOP
43. Turn on ALL.
44. Change the boxes beside PIN and VIA to White.
45. Click Apply and OK
46. OPTIONS > PIN (right hand window)
47. Select FILMMASKTOP.
48. FILE > PLOTSETUP.
49. Scaling factor = 1.
50. Default line width = 10.
51. CHECK THE MIRROR BOX.
52. Colour is checked.
53. Sheet contents is checked.
54. CLICK OK.
55. FILE PLOT to print.
56. Select SETUP
57. Change printer to PDF creator click OK
58. Change dpi to 3600
59. Click OK to print
60. FILE > SAVE.

Disappearing GND and POWER Nets

1. In PCB Editor, EDIT > NET PROPERTIES.
2. In Constraint Manager, NET > GENERAL PROPERTIES.
3. Column NO RAT > remove checks against nets.
4. Exit Constraint manager to display nets.

Or

1. EDIT > NET PROPERTIES
2. In Constraint Manager, NET > GENERAL PROPERTIES.
3. Remove any checks in VOLTAGE column.
4. Exit Constraint manager to display nets.
Creating files for Routing on machine.

Create a board outline
1. Use a cline to mark the outline of the board on the top layer.
2. It will not go all the way round so leave a small gap.
3. Cancel the DRC errors that this generates.

Create artwork
1. MANUFACTURE > ARTWORK
2. General Parameters tab
3. Device Type > Gerber RS274X
4. Output Units > Inches
5. Error action > Abort Film
6. Film control Tab
7. Tick check database before artwork
8. Click Create Artwork
9. Art work is created in allegro TOP.art and BOTTOM.art

Problems
1. Unlisted shapes which are not connected to a net create errors.
2. Co-ordinates of shapes are listed in commands window.
3. Workout what they are and delete them.

Drill file set up
1. MANUFACTURE > NC > DRILL Customisation
2. Auto generate symbols
3. OK
4. MANUFACTURE > NC > NC PARAMETERS
5. Check Enhanced Excellon Format.
6. CLOSE
7. MANUFACTURE > NC > NC DRILL
8. Specify root file name.
9. Set scale to 1.0. (ok to leave blank)
10. Check Auto tool select
11. Check Repeat codes
12. Check Optimise drill head travel
13. Drill to create drill file .drl
14. Close
Creating files for manufacture by PCB Train / Newbury

Files required in Zip File
1. Board Outline.
2. Silkscreen Top.
3. Soldermask Top.
4. Copper Etch Top.
5. Copper Etch Bottom.
7. Silkscreen Bottom.
9. Readme.txt details of design.

Setup
1. SHAPE > GLOBAL DYNAMIC PARAMETERS
2. SELECT Void Control TAB
3. Set Artwork format to Gerber RS274X.
4. MANUFACTURE > ARTWORK.
5. Select GENERAL PARAMTERS tab.
7. Select Leading Zeros.
8. Select Equal coordinates.
9. Set Scale Factor for output to be 1.000

Create Artwork Board Outline.
1. In Visibility side menu turn all On
2. DISPLAY > COLOUR.
3. TURN Global Visibility OFF (top right).
4. SELECT Board Geometry folder.
5. Select SUBCLASS Outline.
6. Change associated colour to be white (visible on Black Background).
7. APPLY and OK.
8. Verify Board outline is visible and correct.
9. MANUFACTURE > ARTWORK.
10. If Board Outline not visible, Right click on Folder in available film and Select ADD.
11. Complete Name pop up with sensible name (BOARD_OUTLINE).
12. In Film Options TAB, set Undefined Line width to be 1.00.
13. Tick Box beside BOARD_OUTLINE.
14. Click on Create Artwork button to create file called BOARD_OUTLINE.art in allegro file folder.
15. Click OK.
16. Save Main design file.
Create Artwork Silkscreen Top.

1. DISPLAY > COLOUR.
2. TURN Global Visibility OFF (top right).
3. SELECT Board Geometry folder.
4. Select SUBCLASS Silkscreen_Top.
5. APPLY and OK.
6. Verify Silkscreen_Top is visible and correct.
7. MANUFACTURE > ARTWORK.
8. If Silkscreen_Top not visible, Right click on Folder in available film and Select ADD.
9. Complete Name pop up with sensible name (SILKSCREEN_TOP).
10. Tick Box beside SILKSCREEN_TOP.
11. Click on Create Artwork button to create file called SILKSCREEN_TOP.art in allegro file folder.
12. Click OK.
13. Save Main design file.

Create Artwork Soldermask Top.

1. DISPLAY > COLOUR.
2. TURN Global Visibility OFF (top right).
3. SELECT Stack-Up Folder.
4. SUBCLASS Soldermask_Top, select PIN and VIA.
5. APPLY and OK.
6. Verify Soldermask_Top is visible and correct.
7. MANUFACTURE > ARTWORK.
8. If Soldermask_Top not visible, Right click on Folder in available film and Select ADD.
9. Complete Name pop up with sensible name (SOLDERMASK_TOP).
10. Tick Box beside SOLDERMASK_TOP.
11. Click on Create Artwork button to create file called SOLDERMASK_TOP.art in allegro file folder.
12. Click OK.
13. Save Main design file.

Create Artwork Copper Etch Top.

1. DISPLAY > COLOUR.
2. TURN Global Visibility OFF (top right).
3. SELECT Stack-Up Folder.
4. SUBCLASS TOP, select PIN, VIA and ETCH.
5. APPLY and OK.
6. Verify Copper Etch Top is visible and correct.
7. MANUFACTURE > ARTWORK.
8. If TOP not visible, Right click on Folder in available film and Select ADD.
9. Complete Name pop up with sensible name (TOP).
10. Tick Box beside TOP.
11. Click on Create Artwork button to create file called TOP.art in allegro file folder.
12. Click OK.
13. Save Main design file.

Create Artwork Copper Etch Bottom.

1. DISPLAY > COLOUR.
2. TURN Global Visibility OFF (top right).
3. SELECT Stack-Up Folder.
4. SUBCLASS Bottom, select PIN, VIA and ETCH.
5. APPLY and OK.
6. Verify Copper Etch Bottom is visible and correct.
7. MANUFACTURE > ARTWORK.
8. If Bottom not visible, Right click on Folder in available film and Select ADD.
9. Complete Name pop up with sensible name (BOTTOM).
10. Tick Box beside BOTTOM.
11. Click on Create Artwork button to create file called BOTTOM.art in allegro file folder.
12. Click OK.
13. Save Main design file.

Create Artwork Soldermask Bottom and Silkscreen Bottom.

1. As above with different names

Create drill file

1. MANUFACTURE > NC > NC Drill.
2. Edit Root file name *.drl.
3. Set scale factor to be 1.0.
4. Tool sequence to be increasing.
5. SELECT Auto tool select.
6. SELECT repeat codes.
7. SELECT Optimize drill head travel.
8. Drilling Select Drilling by Layer pair.
9. SELECT NC Parameters Button
10. Set EXCELLON FORMAT to 2.5.
11. Offset X to 0.00 and Y to 0.00.
12. Select Enhanced Excellon format.
13. Click close.
14. Select Drill button to create drill file.
Hints and tips

Tracks highlighted in PCB editor.
Tracks which have been selected in PCB schematic designer will be highlighted in the PCB editor. This allows users to see where all the particular parts of a net are. To de-highlight, un-select the net or part of a net in Schematic editor, go to PCB editor and select DISPLAY > DEHIGHLIGHT. It helps to use the general edit mode. Other parts such as symbols can get highlighted as well.

Display Options Menu
1. Lost the option menu on the right hand side of the screen? Beside find and Visibilty?
2. VIEW > RESET UI TO CADENCE DEAULT.

Set DRC limits
1. SETUP > CONSTRAINTS > CONSTRAINTS MANAGER
2. On left WORKSHEET SELECTOR > SPACING
3. Set minimum gaps in relevant boxes, example line to via.
4. Click update DRC button on menu.

Change width of Clines
1. EDIT > CHANGE
2. Opens Board Geometry in Options Pane.
3. Check line width box, change value to required value.
4. In FIND Pane, select All Off, Select Clines or Cline Seg as required.
5. Click on Clines to change them.

Errors

Error 32007
Wrong footprint assigned to part, too many or too few pins,
or Footprint names over 32 characters long

1. In Capture, TOOLS > CREATE NETLIST.
2. PCB editor Tab > SETUP button
3. In Setup Popup, Miscellaneous section, Device/Net/Pin/Name Char limit set to 255.
4. In PCB editor. SETUP > DESIGN PARAMETERS
5. Design TAB, Command Parameters, Longname size SET TO 255

Error 32006
Problem finding footprints when net listing, make sure psmpath and padpath are correctly referenced.

Also when student renames devices no special chars are allowed (/_. Etc)
Error 36004
In a multi-part device (4 op-amps per IC) if one pin is changed properties (output to NC) it changes numbering so that it causes an error when netlisting.

Add identical parts, add footprints, delete the exiting parts and add the new parts, renumber the ref des. Do something sensible to the pin, tie it to gnd or power via a resistor.

Design freezes in window
Unable to move around PCB or the zoom function does not work.

Cause - locking PC, or screen saver - power saving activating.

Resize the window by double clicking on the blue bar at the top of the screen.

Pinning Option Find and Visibility windows
Move the mouse over to the right of the window and hover over either of the menus.

A pop out menu will appear, at the top of each of these is a drawing pin icon. Clicking on the icon will pin the window to always be on top.

On some older PCs / monitor combinations, this can cause a graphics glitch, where only the part the mouse is currently hovering over is displayed the rest is blanked. As the mouse is moved around the screen, parts jump out of the darkness, making it difficult to locate the required part.

The solution is to unpin the Option, Find and Visibility menus.

Changing Text Size
1. EDIT > CHANGE
2. In Options Tab, Class, Select Board Geometry
3. In New subclass, Select Silkscreen Top
4. Alter the Text block size to control size of text.
5. Click on text on board to change it.
6. For in house boards with no silkscreen, use Class ETCH and subclass TOP or BOTTOM TO etch Straight on to the copper layer.
Create Parts in Schematic capture

1. Select project overview page.
2. FILE > NEW > LIBRARY (create a new library as standard library does not accept user generated parts only parts from the OrCad main Libraries.)
3. Right Click on newly created Library and select NEW PART, This opens the New Part Properties Box.
4. Enter a name for the part. (no spaces, keep it short)
5. Select a ref designator for the part (R resistor, C capacitor, U IC, etc.)
6. Assign a footprint, or leave blank to assign later.
7. Enter parts per package (e.g. more than 1 op-amp per IC)
8. Select Homogeneous or Heterogeneous (if the part contains multiple devices, homogeneous parts are the same e.g. 7 inverters per part, heterogeneous parts are different, parts of the a relay (normally open switch, normally closed switch, coil)).
9. Part numbering, select alphabetic or numbers to use letters or number for pin names.
10. Select OK to create the part which will open in a new window.
11. Reshape the part outline by clicking to highlight the outline then moving the squares in the corners.
12. PLACE > PIN to add pins to the device.
13. In the Place Pin Box, enter a name for the pin and assign it a number.
14. Do not duplicate names or numbers, use sequential numbering.
15. Select shape defines how the pin is represented.
16. Select type defines what the pins type is. (Useful for design rules check so that 2 inputs are not connected together.)
17. Ok to place pin, move mouse round part outline to select location for the pin.
18. Place another pin with the same name, by moving to a different location and left clicking.
19. Right click, END MODE to finish placing pins, with that name.
20. Repeat to place pins with different names.
21. When all pins are placed, draw an outline using the PLACE RECTANGLE tool.
22. Save part.
23. Close page.
24. Select Sheet device is going to be used on.
25. PLACE > PART
26. On Place Part menu select dotted box to add a new library.
27. Navigate to the directory the design is saved in and select the library that was just created.
28. Highlight the new library to show the list of parts contained in it, select the part created to add it to the design.

Think about where to save libraries so that they are accessible for other projects.
Make a new master library folder and add it to the design to create a new schematic part, this keeps all the parts together and next time we need the part we do not have to make it we just draw it from our personal library.

Creating Footprints In PCB Editor

1. Work out Dimensions from data sheet
2. Build device using default pads that work. (GU-PAD100sq35d.pad)
3. Evaluate pad size
4. Alter pads and save new pads.
5. Save new footprint / recreate foot print using new pads.
6. Move pads to local directory which PCB editor has access to build footprints.
7. Test with schematic and PCB designer.

IN PCB editor

TOOLS > PADSTACK > MODIFY LIBRARY PADSTACK

In Designer

Alter sizes in parameters and layers

FILE > SAVE AS

Change file name and save in a sensible location.
EDP2 Common Problems

EDP2 Foot print Libraries not found.
The library issued by Prof Davies need to be saved on the students network drive.

The schematic library can then be accessed in capture by navigating to the new directory using the Add Library feature of Place parts.

Unique footprints and pads need to be referenced in PCB editor, in the same way the standard parts are on the Q APPS directory.

Wrong footprint
The difference between surface mount components and through hole components is important.

Not enough pins on schematic part for foot print
Some of the parts in schematic editor have fewer pins than the associated footprint. For example some Opamps have 5 active pins (inverting input, non-inverting input, output, ground and power). The standard IC will have 8 pins, 3 no connect pins need to be added to the part and labelled correctly and set to be no connect (N/C).

Switch numbered incorrectly
A standard 1 pole switch will have 1 common terminal and 2 others. The common will be connected at all times to one of the other connections. The default pin number for the common is usually pin 1. In practise the common is the middle (pin 2) of a line of 3. Care need to be taken to assign the Schematic pins to relate to the actual physical pins.

Care need to be taken in the editing process, students can move the numbers to be beside the pin they require. Moving the number still leaves it associated to the pin it was assigned to, it is just in the wrong place. The pin needs to be edited (right click edit part, right click edit pin) not moved. Care needs to be taken not to have 2 pins assigned with the same number.

Standard via used, Not GU-VIA 80
PCB editor need to be set up so that the standard Via is replaced with GU-VIA80, and the standard Via deleted. (Setup > Constraints manager. Physical > All Layers > Vias) The standard via is Ok for through hole plating, but that is not offered by the workshop. The GU-VIA80 can be soldered by the students, unlike the standard part which is very small and prone to open circuits. If soldering the standard Via, bend the wire flat to the board and solder it to the track.

Tracks / pins / symbols highlighted in masks.
Sometimes Tracks pins symbols can become highlighted with a check effect, this means any photomask created with them is corrupted. If schematic editor is open check the track, pin, etc, is not selected, as highlighting in schematic editor will highlight in PCB editor (it is a feature).

In general edit mode, select whatever is highlighted and use the de-highlight command. It is not always tracks that get highlighted, pads in footprints, or parts can be selected as well.
Scaling issues with Photo-masks.
Photo-masks need to be scaled correctly otherwise component, especially large 20 pin connectors, will not fit when the board is made.

In Plot setup, scaling factor = 1, colour, sheet (not screen) contents.

When printing from adobe (recommended), set actual size (not fit to page).

Using PSpice battery symbol in Schematic Editor
No footprint can be assigned to the PSpice battery symbol in Schematic Editor. No connections are made in PCB editor for the battery. Change the battery to a standard battery or use a 2 pin connector and label it with voltages. Make sure the pins on the connector are correctly assigned.
Magical multicolored pads problem, no holes on photomask. ?????

Text on photomask to small and too thin.

New problem,

Changing the scaling factor to make the board outline thicker changes the width of the pads.

How to change the width of the board outline without changing the pads, printing to PDF?

BOARD GEOMETRY OUTLINE is a line standard width = 0.
In the FIND menu ensure LINE is selected.
RIGHT CLICK on the Board Geometry Outline, select CHANGE WIDTH.
Enter size 20.

Route Keepin and Package Keepin are shapes.

Adding Text Setup up

SETUP > DESIGN PARAMETERS
Select TEXT tab
Select SETUP TEXT SIZES

In PHOTO WIDTH column enter, 4,6,8,10,12,14,16,18,20

Click OK to close text editor and OK to close design parameters.

To add Text

Select ADD, Select ADD TEXT, This changes the OPTIONS WINDOW

ACTIVE CLASS > Select ETCH

AND SUBCLASS > Select desired Layer (TOP or BOTTOM)

IF Bottom Layer selected, select MIRROR

Select TEXT BLOCK 5, for optimal printing.

Left click to place text in desired location and type.

Text can be moved and spun.