Week 7:
Design a Logarithmic Voltmeter

A variation on Experiment 19
Validation by 8pm on October 14
Op Amps

• Will not work if V+ and V- are not connected to +9V and -9V, respectively.
• Will get extremely hot if V+ and V- are wired backwards
  – Temperature of chip can melt the white plastic of the ANDY board.
    • Remove the power to your ANDY board if you think that your op amp is overheating.
    • Allow it to cool before removing the dip package.
    • Replace the chip with another one rather than reusing the overheated one.
Limitations of Student PSpice

• 64 nodes
• 20 components
  – Complex parts, such as some of the Op Amps, count as more than one component.

You will not be able to simulate the operation of your entire voltmeter circuit because of these limitations. Break the circuit into subcircuits.
Debugging Your circuit

• The best way to determine why your circuit is not functioning as expected is to separate out the subcircuits and verify that they work as designed – i.e., measure node voltages and branch currents and compare them with your calculations and PSpice simulations.
  – Start at the subcircuits at the beginning of the circuit.
    • Voltage dividers that are used to define the unknown voltage and the reference voltages for the comparators.
  – Work your way to the LEDs.

• The best way is not to pester the OpEL GTAs until they rebuild your circuit for you.
  – Reasonable amount of assistance from the GTAs is acceptable.
    • If you do not know what the voltages should be at certain points of your design, this could impact your validation grade.
Using the Velleman Oscilloscope
Sine wave with a DC offset

\[ V(t) = A + B \sin(2\pi ft) \]

- \( f \) = frequency in Hz
- \( A \) = DC offset voltage (average voltage)
- \( B \) = Sine amplitude

- \( V_{pp} = 2B \)
- \( V_{max} = A + B \)
- \( V_{min} = A - B \)

120 \( V_{RMS} \) from the AC line

- has a peak voltage of 170V
- has a PP voltage of 340V
- \( A = 0, \ B = 170, \ f = 60 \)
Remember this:

• sin(x) varies from -1 to +1

  so Bsin(x) varies from –B to +B and (for voltages) Vpp = 2B

• The scope has an “Amplitude” measurement that is actually the same as Vpp.

  Amplitude on the scope ≠ B

• The DMMY64 assumes all time varying signals are sinusoids.

  This meter will provide an AC_rms measurement for pure sinusoids; it will not accurately measure anything that is not either pure DC or a pure sinusoid between 40Hz and 400Hz.
Oscilloscope Basics

• The scope graphically displays a time varying voltage waveform.

• The scope can be used to determine waveform amplitude, frequency, period, phase, DC and AC components, noise, shape, etc.

• NOTE: The oscilloscope is designed to capture and display time varying waveforms – it is not the best instrument for measuring DC voltages!
Displaying the input waveform.

- An A→D converter captures a series data points on the waveform. The 8 bit samples provide a resolution of 256 possible voltage levels.

- These points are stored in memory and then displayed on the screen, using interpolation to smooth the waveform shape between data points.

- The accuracy and resolution depend on the vertical scale selected. For best measurement accuracy, you should always try to display the waveform as close to full scale as possible.
Main Oscilloscope Components

• **Vertical display controls**
  Scales the input voltage to set the size and position of the waveform.

• **Horizontal display controls**
  Sets the “sweep rate” (time / division) and adds a horizontal position control.

• **Trigger System and controls**
  If the horizontal sweep begins randomly, the waveform moves around.

  The trigger stabilizes the waveform by controlling where, on a waveform’s voltage and slope, the display trace begins each time.

• **This scope also has a built-in signal generator.**
The Velleman scope display
Vertical controls

- Turn the channel display on & off (toggle the **On button**)
- Set the vertical scale (press desired scale on **Volts/Div.**)
- Set vertical position (**slide bar**)
- Set input coupling (select **buttons** at bottom)
  - use 1x for the black coax probes from Electronix Express.
  - use 1X or 10x for the probe supplied with Velleman scope
- **Autoset can be friend or foe!**
Scope Input Coupling

Input coupling may be:

- **DC Coupling** displays all of a signal, including any DC offset. True RMS measurement requires DC coupling.

- **AC coupling** strips the DC component from a waveform, leaving only the time varying portion of the signal.

- **GND** disconnects the input signal.
Horizontal controls

• To the right of the waveform display area is the Time/Div. horizontal scale setting buttons.

• The Run button enables the Horizontal display.
• The single button is used to display a single horizontal capture.

• Below the waveform display area is a slide bar to move the waveform sideways along the horizontal scale.
Trigger controls

- Turn the trigger on and off (use the buttons). If the trigger is off, the display will free run.

- If the trigger is on and you see Waiting for trigger...

  Select the trigger source (buttons)

  Select whether to trigger on rising edge or falling edge of the waveform. (buttons)

  Adjust the trigger voltage level (slide bar) until you see Running.
Trigger markers tell you what the trigger is doing.

There are markers on the edges of the scope waveform display that correspond to the waveform’s

- trigger voltage level
- trigger time (appears when you move the horizontal position slide bar to display the waveform before the trigger occurred)
Signal Generator built into the Scope

- Generates sine, square, and triangle waveforms, plus other functions. Select the waveform type with the buttons.

- Select frequency range with the buttons, then adjust the frequency with the slider.

- For Amplitude and DC offset, adjust the levels with the sliders or type the values into the boxes.

The generator output (here) is set for a 500Hz, 5Vpp sine wave with a 0.98V DC offset - into a high Z load.
Starting the oscilloscope

1. Install the scope software from the Velleman web site - not the CD

2. Install the USB drivers from Velleman web site - not the CD

3. Attach the scope to the USB port

4. Launch scope control software

   Start > Programs > Velleman > PcLab2000LT

   (You will probably want to make a shortcut)
What if the software doesn’t find the scope?

- You may see a pop-up that says you are in Demo mode because the software did not find the scope.

  This is usually not a problem.

- Click Options > Hardware Setup > PCSGU250 > OK

- The software will find the scope and the blue light will illuminate on the front of the scope.
If you still can’t get the scope to connect...

• Make sure that you installed the software and drivers from the Velleman website. The CD included with your scope does not contain the latest versions.

Try re-installing the drivers from the Velleman web site.

• See the ECE Tech support Guru for assistance.
  Branden McKagen
  bmckagen@vt.edu
  346 Whittemore Hall
  9:00-Noon and 1:30-5:00 Monday – Wednesday and Friday
  1:30-5:00 Thursday

• If you have a scope that will not work, see a GTA in the OpEL for assistance.
Your scope is connected, what now?

• First do a calibration.
  With no cables connected to the scope,

  Click Options > Calibrate > OK

  Wait for the Calibration complete pop-up and click OK

• Always run a calibration before you begin measurements if the scope and/or computer have been off.
Connecting the Generator and Scope to a load

Connect the probe leads from the scope CH1 input and the scope Generator output to the load resistor on the protoboard.

Insert wires into the breadboard and clip the probe leads to the wires.

Do not attach the measurement clips directly to the load resistor.

• The heavy probe leads may pull the resistor out of the breadboard

• Using wires makes it easier to change the resistor value.
Set up the scope’s Signal Generator

- Select the waveform type with the buttons.

- Select frequency range with the buttons, then adjust the frequency with the slider.

- For Amplitude and DC offset, adjust the levels with the sliders or type the values into the boxes.

In this case, the generator output is set for a 500Hz, 5Vpp sine wave with a 0.98V DC offset into a high Z load.
Set up the scope for measurements

1. Connect a BNC / Clip lead from the signal to be measured to the CH1 and/or CH2 Input(s).

2. Click Run.

3. Turn on the Trigger and the CH1 and/or CH2 display(s).

4. Adjust the vertical, horizontal, and trigger controls to get your waveform on the screen.
Visually measuring the waveform

On the scope display, Vmax, Vmin, Vpp, and period can be obtained by

- counting the number of divisions
- multiplying by the vertical scale for voltages
- multiplying by the horizontal scale for time period.
Measure the Waveform Parameters

- Click View > Waveform Parameters...
  This opens a pop-up for measurements.

- Click each box to place (or clear) a check for measurements you wish to include (or exclude).

  DC Mean is approximately the DC offset
  AC RMS is $V_{\text{RMS}}$ without the DC offset
  AC + DC RMS is the True $V_{\text{RMS}}$
  Amplitude is the same as Peak-to-Peak
“Waveform Parameters” Accuracy

• A waveform that vertically occupies most of display will have more measurement accuracy than a waveform that is small on the display.

• Best accuracy seems to require at least two waveforms horizontally.

• The measured values will be reasonably accurate as long as the scope display is running.

• If you see “?” after the value, the waveform measurement does not fit into the display window and is out of measurement range.

• If you have “Waiting for trigger” showing, any waveform changes will not appear in the display or Waveform Parameters measurements.
Using Cursors

To obtain data at specific points on the displayed voltage vs. time graphs, you can turn on the cursors by clicking on Markers (DSO) under View on the scope toolbar.
To find the difference in time between two points in time on a curve, position the two vertical lines by click-and-dragging each line to the appropriate point on the trace.

\[ dt \] is the absolute value of the difference in time between the two vertical cursors. \[ 1/dt \] is the reciprocal of that difference in time, expressed in Hz.
To find the difference in voltage between two points on the same trace, position the two horizontal lines by click-and-dragging each line to the appropriate point on the trace.

dV is the absolute value of the difference in voltage between the two horizontal cursors. The two voltages in parenthesis after dV are the voltages used in the calculation of dV.
You can use the cursors to find the difference in voltage between the two traces. However, you should make sure that the coupling on Channel 1 is the same as the coupling on Channel 2,

DC coupling on both channels will enable you to measure the difference in voltage between the two traces using ground as a reference voltage.

AC coupling will only allow you to determine the difference in the ac portion of each signal.

You should not use two different types of coupling.
In this week’s lab

- You will use the Velleman function generator as the ‘unknown’ voltage source.
  - For your lab report:
    - You will set the function generator to ramp the voltage from -5V to +5V and connect the output of the function generator to the input of your voltage comparators.
    - You will use the oscilloscope to measure the voltage from the function generator (CH1) and measure the voltage of one of your operational amplifiers.
      - Show that the output voltage of the op amp switches from -9V to +9V as the voltage of the function generator increases above a predetermined value.
      - Use the cursors to measure the voltage outputted by the function generator at the time the op amp output switches.
        » Save a screenshot to include in your report.
For validation

• Bring your Velleman scope with you.
  – You will use the Velleman function generator as the ‘unknown’ negative voltage source and as an ‘unknown’ positive voltage source.
  • Show the GTA that the correct LEDs are lit.